So I found a driver installer for the function keys that was supposedly for Toshiba r15-s829.

Next thing I know the time is October 14, 9999 (or whatever is xp’s upper limit) and I had to use the “boot up from previous best settings that the computer still worked in” because i had just backed it up a week prior and I already had 10 different things that I changed.
do you need to try a different driver than toshiba's for the FN keys to work?

you might have to download several from different driver sites and try one at a time. I am surprised that the toshiba one did not work, are you sure it was the correct one and not the latest version, sometimes the latest version of a driver is not the correct one, the bios for my pc can go to A10, but dell recommends only up to A03.
NO, that is why I said that you had to be careful with third party driver download sites. I tried several just to test and that is the bios that was supposed to work on my pc, but I did not install it. I did try some usb drivers, but they did not work so I just did a clean install and used all my normal drivers that I downloaded from Dell way back when, :)