SATA HDDs with A7N8X-E Deluxe motherboard

Discussion in 'Windows XP Hardware' started by MisterEd, Mar 13, 2023.

  1. MisterEd

    MisterEd

    Joined:
    Mar 8, 2022
    Messages:
    115
    Likes Received:
    49
    Location:
    Huntsville, Alabama USA
    The ASUS A7N8X series motherboards is probably one of the first to support SATA drives. In fact when I bought a A7N8X Deluxe motherboard in 2002 there weren't even any SATA HDDs for sale. When this board failed I replaced it with a A7N8X-E Deluxe one. I tried setting the A7N8X-E Deluxe up to use SATA HDD by enabling in the BIOS and installing the driver. Unfortunately, I couldn't get it to see a SATA drive. Does anyone know if there is a problem with such an old SATA motherboard working with a modern SATA drive?
     
    MisterEd, Mar 13, 2023
    #1
  2. MisterEd

    TMTGTR

    Joined:
    Nov 20, 2021
    Messages:
    204
    Likes Received:
    124
    Location:
    New York
    I'm feeling around the dark here.
    If I am recalling correctly, there are SATA drive spec levels (Like USB 1.1 vs. USB 2 vs. USB 3) So I think there are something like; SATA I SATA II SATA III, but this is off the top of my head. If that is the case (no pun) I'd say odds on that is what is at issue. You may need a BIOS update/hack or a really old SATA I drive. I thought though that SATA II is backward compatible and I have old machines that do not complain.
     
    TMTGTR, Mar 13, 2023
    #2
  3. MisterEd

    MisterEd

    Joined:
    Mar 8, 2022
    Messages:
    115
    Likes Received:
    49
    Location:
    Huntsville, Alabama USA
    [​IMG]

    Most of my older SATA 1.0 and SATA 2.0 drives failed long ago. I only have the two above left. All the other SATA drives are SATA 3.0.

    I suspect the newer SATA 3.0 drives will not work with an old motherboard with SATA 1.0. BTW, I think I remember having a SATA 2.0 drive that had a jumper for compatibility with SATA 1.0 in case it was needed.

    Back when I did have SATA 1.0 and SATA 2.0 drives I didn't bother trying them with the motherboard because the IDE drives I had worked fine. Also, back then SATA drives were more expensive so were not worth the expense.

    Since SATA 1.0 and 2.0 drives have not made in over 10 years there is nothing left worth buying. My only option may be with a SATA to IDE adapter with this motherboard. The last SATA drive I tested with this failed. When I try with this again I will probably try using the 300GB drive shown above. It is the oldest SATA drive I have so if lose it, it won't be as much of a loss.
     
    MisterEd, Mar 14, 2023
    #3
    TMTGTR likes this.
  4. MisterEd

    TMTGTR

    Joined:
    Nov 20, 2021
    Messages:
    204
    Likes Received:
    124
    Location:
    New York
    I see. Thanks for the SATA info. best of luck!
     
    TMTGTR, Mar 14, 2023
    #4
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.