Problem running backup as user

Hey everybody,

I have the following setup:
-a server running on Ubuntu which is providing a network storage via Samba (user security)
-several Windows PCs which should back up their data on the network storage of the server
-all devices are in the same network
-used backup program is PersonalBackup

How i want it to work:
-Windows computers run a backup of a certain folder automaticaly once a day (this runs via Windows tasks using admin credentials)
-users must not have administrative rights but should be able to back data up on demand (anytime they want)
-in both cases the program uses the same login credentials for the server, which is neither identical to the admin user nor the usernames

The problem:
-everything is fine for Windows 7 and Windows 8 systems except for Win XP
-in Win XP i can not run a backup on demand while loggged in on a user account (network access failed, pinging the server via cmd works)
-if i use the admin account for my backup on demand it works without any errors
-also tried several things with the firewall (disable/enable, with/without exceptions for Personalbackup) nothing works

Do you have an idea?

Kind Regards,
Last edited:

since this seems to be a program issue, I would check at their website (above), there is on the left, Online Help, :)
Since I am able to run it under Win7 and Win8, both as admin and as user, I dont think its a bug of the software. I mean, I can run it under XP as admin, but not as user.
For further validation I tried to run a backup on demand as user to a local directory, which worked. So this should be a Windows problem which is not allowing my program to connect to the network drive.
In any case, there is a way to force Windows to make the network drives available to both the standard and administrator accounts automatically. All you need to do is run Registry Editor (regedit.exe), locate the following key:


and create a new DWORD entry with the name EnableLinkedConnections and value 1:

above from here, but I am not sure of this as I do not run a backup program and I am not on a network, :)