NIC disabled on start up

I installed new drivers for both nic's and now every time I restart the laptop I have to go in and enable the Realtek wired NIC card. I disabled the wireless card because I have the laptop directly hooked to my Linksys router. What can I do to fix this? Thanks for any help you might be able to give me.

Acer Aspire 9500,
1.6ghz Celeron M
Windows XP Home SP3 up to date
2GB ram new
Intel 915GM/GMS 910GML Express chipset
NIC wired Realtek RTL8169/8110 Realtek driver 5.719.325.2009
NIC wireless Atheros AR5005G "Disabled because directly wired" Acer driver
Last edited:
Wow this forum is dead! I look at the replies to the questions. If there is a moderator on this forum they should at least say they don't know.
Sorry about the slow reply, I've been away for the past few days and only got back to see this :).

Can you try this please:

Open the properties for your ethernet card in the Device Manager, select the tab that provides driver details and copy the driver name.

For Example, mine is >> dm9pci5.sys (for a CNet card).

Now run regedit and navigate to the following key >>

Do a "Find" for the driver name for your card.

In the right pane where this is found you will see a "start" type -- this is "manual" by default (at least it is for mine).

Try either setting it to "automatic", or "boot".

Change Value data to the wanted state:
0 = Boot
1 = System
2 = Automatic
3 = Manual
4 = Disabled

"automatic" can also be configured through the "services.msc" profile.
If yours is set to "manual" I would just set it to automatic to test.
Driver version is 5.623.615.2005 Rthlnicxp.sys
I know there is a latter version on Acer's page. I did install that driver and it caused so many problems I had to do a System Restore just to make the laptop stable again.
Last edited:
I did the 1-4 options that you suggested. Nothing worked or should I say nothing changed that I could see. It's odd, when the laptop is first starting up the icons are there for the network connection and shows a connection for a few seconds then dispears.
Did you try rolling back to the drivers you used before this - I guess it worked ok then?
Did you try rolling back to the drivers you used before this - I guess it worked ok then?

I just did a system restore, so it's back to the same drivers it had before and yes the Realtek did work fine before I did a driver update. This all started because the wireless nic would lockup the laptop a few min after boot if I didn't hit the wireless button on the front of the laptop to turn it off. I still have to enable the Realtek every time I do a restart.
Last edited: