Need Help Uninstalling Corrupt Network Adaptor Drivers

Discussion in 'Windows XP Help and Support' started by Emily Persephone, Jul 4, 2014.

  1. Emily Persephone

    Emily Persephone

    Joined:
    Jul 4, 2014
    Messages:
    2
    Likes Received:
    0
    Location:
    Michigan, USA
    I would like to start by stating that I am very much unfamilar with the more technical side of computers. However, my desktop is having some trouble and I am hoping that someone here can help me, or provide more information.


    Last evening, while I was browsing the internet, I lost the connection. The USB network adaptor is brand new so I knew that was not the problem. I ran the Malwarebytes Anti-Maleware full system scan, and also the Piriform C Cleaner scanner.


    I then checked the device manager and I found little yellow circles with exclamation points beside every network adapter driver. I tried to uninstall the drivers but when I did, a box popped up with the message "Failed to uninstall the device. The device may be required to boot up the computer."

    I then tried to put in the disc to reinstall a non corrupt version of the driver, but my computer did not seem to recognize the installation attempt.


    I have Microsoft Windows XP, Home Edition, 2002 Version, Service pack 3.

    The following are photos that I took of my screen, and photos of the brand new USB network adapter that I am currently using. It was installed in April.


    Thank you to anyone who reads this or is able to help. I appreciate it, greatly!
     

    Attached Files:

    Last edited: Jul 4, 2014
    Emily Persephone, Jul 4, 2014
    #1
    1. Advertisements

  2. Emily Persephone

    Emily Persephone

    Joined:
    Jul 4, 2014
    Messages:
    2
    Likes Received:
    0
    Location:
    Michigan, USA
    More photos for reference.
     

    Attached Files:

    Emily Persephone, Jul 4, 2014
    #2
    1. Advertisements

  3. Emily Persephone

    Elizabeth23

    Joined:
    Dec 10, 2012
    Messages:
    5,093
    Likes Received:
    414
    Location:
    Florida
    Start REGEDIT.EXE and scan for the name of the network adapter as it
    shows up in the Device Manager. You will find an entry in
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet for it. Delete the branch.

    above quoted from here:

    http://www.tomshardware.com/forum/28695-45-problems-uninstalling-wireless-network-adapter
    =================

    does your pc boot to a wired connection?

    have you tried to repair the connection by right clicking on your network connection, wired or wireless, and choosing repair?

    have you tried a system restore to a point before this happened??

    ===============

    side note: Malwarebytes has a new version for the free version yours is outdated.
     
    Elizabeth23, Jul 4, 2014
    #3
  4. Emily Persephone

    Jojo

    Joined:
    May 1, 2014
    Messages:
    179
    Likes Received:
    1
    I don't know if this might be a useful addition to Elizabeth's excellent response, but I have found, for reasons I don't understand, that if I update my networking drivers, networking, ie, net access, doesn't work.

    The last time I accidentally did this, I reinstalled from the hardware disk that came with my machine, in my case, Asus. But you may not have that.
     
    Jojo, Jul 4, 2014
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.