I futzed my desktop! Where does XP store font settings?

Discussion in 'Windows XP Customization' started by ginahoy, Mar 22, 2018.

  1. ginahoy

    ginahoy

    Joined:
    Mar 22, 2018
    Messages:
    10
    Likes Received:
    0
    I'm new to the forum. Like the rest of you I'm sure, I'm a die-hard XP devotee, happy to discover this forum! Better late than never.

    I was experimenting with the desktop font settings (Display Properties / Appearance / Advanced) and made the mistake of not writing down the "before" settings. Now I can't get it back like it was. Does anyone know which file stores these settings so I can restore from a recent backup?
     
    ginahoy, Mar 22, 2018
    #1
    1. Advertisements

  2. ginahoy

    Elizabeth23

    Joined:
    Dec 10, 2012
    Messages:
    4,620
    Likes Received:
    254
    Location:
    Florida
    Windows Explorer and My Computer display the same font that Windows XP uses for icon titles on your desktop: Tahoma, 8 point. If you want to change the font or font size used in Windows Explorer, follow these steps:

    1. Access the Display Properties dialog box by right-clicking the desktop and selecting the Properties command.
    2. Select the Appearance tab and click the Advanced button.
    3. Select Icon from the Item drop-down list.
    4. Use the Font drop-down arrow to select a font from the list.
    5. Click OK twice — once to close the Advanced Appearance dialog box and once to close the Display Properties dialog box.
      ===============================
    6. Fonts are located at: C:\WINDOWS\Fonts
     
    Elizabeth23, Mar 22, 2018
    #2
    1. Advertisements

  3. ginahoy

    ginahoy

    Joined:
    Mar 22, 2018
    Messages:
    10
    Likes Received:
    0
    Thanks Elizabeth. I already know how to make changes, and I know where the path to the fonts folder. What I'm looking for is the name/location of the file that stores the settings. If they're stored in the registry, then which registry file? (there are several, IIRC)
     
    ginahoy, Mar 22, 2018
    #3
  4. ginahoy

    Elizabeth23

    Joined:
    Dec 10, 2012
    Messages:
    4,620
    Likes Received:
    254
    Location:
    Florida
    Elizabeth23, Mar 22, 2018
    #4
  5. ginahoy

    ginahoy

    Joined:
    Mar 22, 2018
    Messages:
    10
    Likes Received:
    0
    Thanks for that reference. Unfortunately, that page doesn't apply to XP. The paths HKEY_LOCAL_MACHINE\SYSTEM\GDI or \GWE don't exist in XP
     
    ginahoy, Mar 22, 2018
    #5
  6. ginahoy

    Elizabeth23

    Joined:
    Dec 10, 2012
    Messages:
    4,620
    Likes Received:
    254
    Location:
    Florida
    Ok, found another one, below came from this page

    The default Windows 2000/XP shell font (for Windows Explorer) is Tahoma, and the default system font (for System Properties, Device Manager, etc.) is MS Sans Serif. Back -up your Registry first, the only way to change them is to alter the Registry. Open Regedit and go to:

    HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes

    Edit the "MS Shell Dlg" string value [REG_SZ] in the right hand pane, and modify its "Microsoft Sans Serif" default value to match any other font name installed on your system (e.g., Tahoma). Then close Regedit and restart your computer for the change to take effect.

    Might also need to change the value in

    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\FontSubstitutes
     
    Elizabeth23, Mar 23, 2018
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.