How to disable wmp CD autoplay when wmp is open

Discussion in 'Windows XP Help and Support' started by jack6128, Apr 13, 2013.

  1. jack6128

    jack6128

    Joined:
    Apr 13, 2013
    Messages:
    3
    Likes Received:
    0
    Hi, new here. Searched but could not find answer, so signed up here.

    I just reinstalled XP and downloaded all the MS updates, including WMP 11. I am using EAC to rip CDs to HD and need to have WMP open at the same time. Problem arises when I put a CD into the CD drive to rip using EAC, WMP 11 begins to play the CD. I used Tweakui to disable autoplay, and that works fine as long as WMP is not open. I tried using the Autoplay tab on the properties dialog for the CD drive, selecting "Take no action" for all files. But if WMP is open, it plays the CD when inserted into the CD drive. I checked all of the options for WMP 11, but could not find a way to disable this behavior.

    Is there any hope, or am I stuck with this?

    Thanks,
    Jack
     
    jack6128, Apr 13, 2013
    #1
    1. Advertisements

  2. jack6128

    Elizabeth23

    Joined:
    Dec 10, 2012
    Messages:
    5,140
    Likes Received:
    435
    Location:
    Florida
    http://www.ehow.com/how_6783019_disable-autoplay-windows-media-player.html

    read above and also try this:
    In WMP > Tools > Devices, if you highlight the CD/DVD drive you use to rip a CD, then click the Properties button. In the new window, click the Data CD tab. Is that "Write playlists to CD as M3U (audio only)" selected?

    If so, de-select it. I'm not sure what it does, but worth a try.

    http://vip.chowo.co.uk/wp-content/uploads/jaws/Windows-Media-Player-11-Guide.html

    above link is a guide for WMP on xp and might have a setting to change if the above solutions do not work
    ====================

    Is wmp set as default?

    Why not use wmp to rip cd's?
     
    Elizabeth23, Apr 13, 2013
    #2
    1. Advertisements

  3. jack6128

    jack6128

    Joined:
    Apr 13, 2013
    Messages:
    3
    Likes Received:
    0
    I should have mentioned that I am using XP Home, which does not have gpedit.msc. I can install it gpedit.msc on my Home installation, but the instructions at that link using gpedit.msc only accomplish what I have already done by disabling autoplay using Tweakui and by disabling autoplay using the AutoPlay dialog box in the properties window for the CD drive, and confirming these changes in the registry using Regedit.

    In the WMP 11 installed on my XP Home machine there is no WMP > Tools > Devices. There is a WMP > Tools > Options > Devices, but when I select the properties for that drive all that I am presented with for Playback is: "Digital" or "Analog", and for Rip: "Use error correction". There is no Data CD tab.

    Yes, WMP is set as default. It is the only media player I have installed. But even if I deselect it as the default player for ALL options, including CD playback, it insists on playing any music CD inserted into the CD drive when WMP 11 is open.

    In any case, aside from which program I choose to use for ripping, the behavior that I wish to change in WMP 11 is to have it NOT play a CD when one is inserted into the CD drive when WMP 11 is open. When WMP 11 is closed, no problemo. Inserting a CD into the drive results in no action. But if WMP 11 is open, it insists on playing a cd inserted into the drive. This is the behavior I wish to prevent.

    Jack
     
    jack6128, Apr 13, 2013
    #3
  4. jack6128

    Elizabeth23

    Joined:
    Dec 10, 2012
    Messages:
    5,140
    Likes Received:
    435
    Location:
    Florida
    okay will keep searching, :)

    why can you not close it while using your other program?
     
    Elizabeth23, Apr 13, 2013
    #4
  5. jack6128

    jack6128

    Joined:
    Apr 13, 2013
    Messages:
    3
    Likes Received:
    0
    I can, but would rather not. In any case I found the solution. It is to change the value of DWORD "autorun" at

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom

    ... from 1 to 0. None of the graphical user interface tweaks I tried accomplished this, including TweakUI, CDROM device properties and the gpedit suggestion, which I tried after installing it on my XP Home installation. Now I can insert an audi CD in the drive while WMP is open and it doesn't play :)

    Thanks for the help!

    Jack
     
    Last edited: Apr 14, 2013
    jack6128, Apr 14, 2013
    #5
  6. jack6128

    Elizabeth23

    Joined:
    Dec 10, 2012
    Messages:
    5,140
    Likes Received:
    435
    Location:
    Florida
    I am glad that your issue is resolved, I also found this if it will help in the future:

    Options such as Disable ‘CD Autostart’ For Audio And Data CDs While EAC Running might give you more luck ripping copy protected CDs, but that can be done outside of EAC by holding down SHIFT before and while you insert the CD until it loads as well.

    off of this page:
    http://www.calonet.org/eac-ripping-guide/
     
    Elizabeth23, Apr 14, 2013
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.