Having trouble figuring out how to restore RAID drives

I have an old Athlon XP 3300 computer that I haven't looked over in years, motherboard A7N8X-E Deluxe, on Windows XP (2GB RAM), with 2 500GB separate drives (from the main OS drive) attached to the motherboard SATA ports, and all I know is the person that gave them to me said they're RAID drives (I don't remember if they're striped or mirrored, but I think he said they were RAID 0...

Anyway, he gave them to me because they stopped working right for some reason (or he wasn't able to access the data on them anymore), and he wanted me to look into fixing them... I couldn't figure it out at the time, but I saw some solutions I felt overwhelmed by, like System Rescue CD 1.x `dd` command :grimace: and I don't remember the path I went down or where my notes are on it.

So I'm trying to figure out what to do now, to see if I can recover any data on the drives. I'll attach a pic of where I'm at, in the BIOS RAID manager, which I'm not sure I understand. I haven't worked with RAID in a long time.

RAID Configuration Utility - Silicon Image Inc. Copyright (C) 2004

Create RAID set - (Striped or Mirrored options)
Delete RAID set - (I don't want to try this yet)
Rebuild Mirrored set - (says nothing to rebuild)
Resolve Conflicts - (says nothing to resolve)
Low Level Format - (I don't want to try this yet)
 

Attachments

  • RAID Configuration Utility 2004.jpg
    RAID Configuration Utility 2004.jpg
    286.5 KB · Views: 19
First of all. Do not Low level format.

If the drives you were given were set up as RAID 0 then they are “Striped”.

You cant rebuild a RAID 0 set up ever.

You can Rebuild “RAID 1” Mirrored, RAID 10, RAID 5, RAID 6. All these types of RAID are designed for redundancy. So that is why they can be rebuilt if a drive fails.

RAID 0 is for performance and has no redundancy.

Sometimes RAID 0 Disks built on one type/brand of controller can be initialised and read on another type brand of controller. They will show up as a RAID 0 set.

I have found that RAID 0 can usually be read between Adaptec, Areca and Highpoint contollers. That’s if the RAID 0 set is good and functioning.

I have never used “Silicon Image” I am presuming it is integral to the motherboard in your case.

Since your friend has already told you the disk Raid setup has stopped working, the chances of you recovering the data is limited. Especially if you are using a different RAID Chip/ Architecture.

If they were good they would show up as a RAID 0 set up.

So data is probably gone.

What has most likely happened is that your friend had a loose connection on one drive and that will have caused the RAID 0 set up to fall over

The only thing you can try is to:

“Create RAID set”

Choose “Striped”

You may get lucky. Both drives appear to physically showing up and at least you may get a RAID 0 set that works.

Good Luck
 
Important

Usually the next screen you are presented after you choose striped will be what chunk size you want.

Choose the default. You will be really lucky if your RAID controller highlights a chunk size that is not the top one. That is because your controller has recognised the chunk size the disks are already allocated – go with what ever the controller highlights.
 
The only thing you can try is to: “Create RAID set” Choose “Striped”

OK, thanks, I can try that.

I'm curious however if anyone has used a Linux boot CD with `dd` or something similar to re-establish RAID drives without data loss. I was going down that path and it seemed feasible but this was in the Windows XP / Vista days, and it got more complicated than I cared to follow through on. I wish I'd have done that now!
 
OK so I tried setting the drives to striped... and... the computer is having some sort of freezing issue, but I can't tell if it's even related.

Here's an example:

RH0H5tYD_YKswhxCA97ArvgYkXJfOr-vF6KuXGa_FvtgznnYof-otmyb-akumqlTx3ULjwWBaRRPAlBG0cVhoB1yiHgQsrSsXxuqjpFROY8JIhUe2d4l-UtJvxh-mT83K8U31JHpWb8pHDJ0N2o_7pOAFvdH737tDTYlvdZiFumDYQGepbKlCzZZkueAwOxH51FkiXQgiEkQ2XoMQQc2fUgL-HbbY9Cj1-Fpovb2n3r8jI8tWAUVKEv0grvhMFDX5jtwReR-dvPja-LdIMkbkK-XrCpdJi4JdhFDsVAyzCkwWvd6gihQ_qUS331piUliTX2ER7gJzqdME4rOPl5jYLQJ66FVart5khaSSgfuNyl8zljNikcEhWEfmV1q7tmxPyvpEYIL3vZETxOqGiUgLjBCvuzijsqs3rSEWUXni6LbhuUjLa2cRtKcmy1oPw0YHPFTIDO2LV2KGX7oEoDn-Z2Iiq0W_Jh8EOU_eBjAzJ3GwSjofjw9ziD9jP3X8Pu6FbEhpAouUhZpiCqpMPm9kCgFf0KZFTLbIzH85WU7QkzzRmRU_umWDiVO8nv2PLjaixM5T93-sBjUNYTEpO_DQWCxEBWi15j-13CD8DS-0Hnq0r9ZupQAnfxAxOPy6cjiWxrUgAKmKLTtntXQ-ZRDlEjo0xu0Pprgh2_3JZq4mu3yAA_6PM007PUFrG2u2sIpVA9VhiczBeGRJZ7Vx9PuQYyOVHgW5vJHO1qeXjOC96L1IK2CSEizrF2aze2JYiiwsemERWhq5gvOOYDVuk_1WI63No_v2ZjtOu5c6bJdGg9pP56HsxdiSuUxfMuYC3r_vCl1vLQfYE8BbVRcWrDjA28BCwqiEVEGCBeLilYBcG4WEFkE30zLRJjGNyI3LAHsXJDQtkigCdwx7V_el1RMloeXCiadMY5e_lofEUcr9jpvsF6ryA=w1292-h969-s-no


So, that seemed to take after I typed Y on the keyboard, because on next boot into that utility, it still showed the Set0 Sil Striped Set (which it hadn't before). The problem though, is that on that screen (in the screenshot), and every time I get back into that utility, I can't do anything... it's like the computer freezes up. When I hit anything on the keyboard, I hear a "tic" sound like it's understanding that I hit a key, but it can't do anything with it for some reason. It's similar to when a system is processing (or stuck) and acknowledging that you're hitting the keyboard, but its buffer is overloaded with keyboard presses and saying "I won't accept any more until I'm done processing" (but it could just be stuck).

So... upon rebooting into Windows XP, the drives still aren't recognized.

I can't tell if the RAID is even there now. I'm worried that I've demolished that data if it wasn't already inaccessible.

I've read that it's really hard to delete data on a drive, so I'm thinking there must be some way to recover it, even if it's data nobody cares about anymore.

So, any other suggestion? I could be experiencing a motherboard issue... so I'll be cleaning out the cab again (I did it last year before shelving it again).

Maybe I can try something with Linux 'dd' (maybe through System Rescue CD, even an old version). I don't know. Any advice would be great here now.
 
If you used "Create RAID 0" option, you probably already demolished any data that were on disk. Recovering from HW Raid 0 is pretty much impossible. The only slim chance is if Raid 0 is linear and your first disk is okey, then there is slim chance to recover some data. In case of stripped, data are written to both disk interleaved.
Most HW RAID0 are stripped for performance reasons.

I generaly try to avoid HW raids for personal use. Win2003 provide Software RAID solution (both 1 and 0). Linux have more option.. there is old MD and LVM2 and you can chose a lot of modes both for raid 0,1,5,6 etc. Linux RAID1 is great and easy to recover.

So, I think just give it up and reuse those disks. If stuff on those disks were importand,
that dude should use RAID1 and have some backups too. (RAID1 is not backup).
 
Back
Top