Disk wipe with DBAN doesn't seem to work

I wiped my Internal HDD using DBAN ISO disk twice in Autonuke mode but my XP OS is still there and booting. What could be hapenning?
did you ensure that the correct drive was being wiped, you can use the interactive mode to see what drives are attached.
First I tried the 'Autonuke' because I had nothing connected to the computer. It was completely wiping the 'C' Drive. Then I tried the Interactive Mode. Both times it finished in about 30 seconds and said "Completed without fatal error" and displayed error dev/sda, error dev/sdc and 3 more identical messages. Do you know what these errors are?

Couldn't figure out what was wrong and used Minitool Partition Wizard portable in a USB and it is working fine. I am using Wiping Method DoD 5220.22-M. The partition it is wiping is 417 GB - Unallocated. Shows up as Logical Drive, whatever it means. After 17 hours it has done only 62% of the task and still running. Is it normal to take this long?
complete in 30 seconds?? mine is an 80gb drive and takes 3 hours.

depends on the number of wipes, if DOD long it is 32 passes and can take awhile

Did you burn the dban ISO to a cd, set bios to boot from cd and then run dban?
not sure then, I just used mine recently last month and it still works fine,

it might be the iso was corrupted, try download from HERE and see if it works better