Command Lenght Incorrect

I have a serious question. i will be decribing what i have done to resolve this issue and if anyone has any other advise please feel free to let me know aobut it.

First, i had to down load microsoft security essentials for a class i am in. During the install i was directed to download a rollup package. I did this and everything went smoothly. i was asked to restart my computer as normal, which i did and everything went normal. Windows booted and when i got to the log on screen as normal i put in my code. At that moment, i recieved an error message stating: The system cannot log you on due to the following error, The program issued a command but the command length is incorrect, please try again or consult your system administrator.

Alright, this is all i have done to correct this problem
1. i tried to log on into safe mode( will not let me access)
2. Tried " last good known config" (boot into the same problem)P
3. Tried the recovery disk( not for my version)
4. Downloaded unbuntu boot disk( took to long to boot)
5. downloaded hirens 15.1 boot disk, Hirens 15.1 disk did boot into mini xp and i have tried to fix from there. the windows error is tricky to me. I have this boot disk but i do not know where to apply the fixes on the disk to my windows. In other words this error dose not tell me where to go an look for the problem.
6. i renamed the c volume with a 7 letter arrangement( did not work)
7. i can not log into admin( error pops up)
8. reset the mbr
9. ran a chkdisk
10. ran a short and long mem test
11. deleted bios password( nothing)
12. fixed boot(nothing)
13. new mbr( nothing)
14. in the hirens went and uninstalled the windows update(nothing happend)

i have done so much its wild. The hirens allowed me to access my hard drive and my information is still there. Each test i have run all came back fine. I had always taken care of my computer and i run weekly anti virus and mal ware checks. I do not know where to go from there. i am at an complete lost. Any suggestions will be accepted.

Thank you.....

PS. i have attached a picture of the error file. in the attachement. Also i have it link able below

pps. im running windows xp pro sp 2


  • IMG_20120713_164348.jpg
    86.9 KB · Views: 431