Cannot connect to available wireless networks


I have Toshiba Satellite A75-S211 and I am having trouble connecting to my wireless internet.
I get connectivity just fine using an ethernet cable.

My Machine will search and find the network, but it does not connect nor does it ask for a password.

Please advise
Thank you for your reply.

I tried running the tool, however, it failed as it stated it could not shut down zero configuration. I have check in the services and made sure that it is running. Under Wireless Network Connection I see that under the General Tab it states "Connect using Athersos AR5004G. Under Wireless Networks tab it is check to "Use Windows to configure my wireless network settings."

Windows can find my wireless network, but, it is still trying to auto connect. It continues to fail as my network is secure and requires a password - it is not asking for the password.

Any other options you can think of that I can try, Elizabeth23?

Thank you for your time and help.

Kind regards


on this page do you have all 3 installed?

you might need the third one.

the link I gave in my last reply may not be working because it does not say for atheros.

This article helps you stop the Broadcom Wireless LAN Tray Service, Dell wireless WLAN Tray Service, the Intel PROSet/Wireless SSO Service, and the Intel PROSet/Wireless WiFi Service, and enable the Windows XP Wireless Zero Configuration service and set it to automatic.

go to above, there are 192 hits at toshiba for wifi troubleshooting, I tried to just have it search for xp, but it would not.

this link has some info on the atheros wifi driver, please read this one first. :)