Boot fails from all devices -

Any ideas welcome!
Over the weekend, I looked at a friends Gateway Emachine from around 2005, 80 Gig HD, which was half empty, 1 Gig of RAM, and Windows XP SP3.

Booting from hard drive goes to endless loop: emachine splash screen to the Windows Boot Options (safe mode, etc.) and back again, then back and forth forever. It won't boot normally, won't boot into Recovery, or Last Known Good, and it won't boot into any of the safe mode options.

The HD was spinning and I could copy her data files off it with another computer. Tested for malware from that other computer, found nothing.

Set the boot order to the CD first.
Wouldn't boot from an XP install disk.
Wouldn't boot from three different Linux live CDs.
Wouldn't boot from a Hitachi drive diagnostic CD.
Wouldn't boot from a Hiren's Boot Disk CD.
Wouldn't boot from a USB drive, though there was an option in bios to do so and it was enabled.

The only thing that would boot was MemTest86+ on a linux test disk called Inquisitor - but Inquisitor itself would not boot.

Disconnected everything, same result.
Tried different cables, etc., same result.
Reset bios to defaults, pulled battery, same result.
Got a couple stop errors, all with same explanation: new or incompatible hardware or faulty driver. There was no new hardware, and I couldn't get at the thing to remove or re-install drivers.
Memory tested OK.

All this argues hosed boot sector/MBR, or faulty IDE controller or bad MOBO, but I couldn't help thinking there was something simple I was missing. I cannot run anything to try fixboot/fixmbr ----it's driving me crazy - and I searched on every phrase that seemed relevant, getting no results that I had not already tried, and that's driving me crazier. :mad:

Has anyone experienced anything like this and found a solution?
Any suggestions will be greatly appreciated!