android tethering

Discussion in 'Windows XP Networking' started by Aaron1983, Jan 10, 2013.

  1. Aaron1983

    Aaron1983

    Joined:
    Jan 10, 2013
    Messages:
    1
    Likes Received:
    0
    Good Evening,

    I have spent about 48 hours trying to work this out with no luck. I am not sure if this is the best place to ask this question because I feel like I need to find someone that is an expert with 1) Windows XP, 2) wireless networking and 3) Android Wifi tethering.

    If there is such a wizard, point me to the yellow brick road.

    I have an Alienware laptop circa 2007. It runs XP professional. Exact hardware/software profile available upon request.

    I have a Dell Latitude 630, property of the United States Government. It runs Windows 7 Enterprise.

    I have a Toshiba Thrive Tablet that runs Android 4.0.4.

    I have a Motorola Droid Razr HD Maxx cellphone that runs Android 4.0.4. and an application called "Wifi Tether." (available in the Google play store).

    I am able to put the tablet and the government laptop on the Internet via the Wifi tethering app on my cell. They see the hotspot, acquire an IP, and surf with no issue. Which surprised me considering the army issue laptop is a paranoid schizophrenic.

    However, my personal computer (the Alienware running XP) cannot. It connects to the network. It acquires an IP address. It sends about 80 packets and receives about 10. Then nothing. It is even more infuriating because it will occasionally garner enough packets to actually display the Google logo on google.com. And then the packet flow just stops. No browsing, no Pandora, no Steam. No happy times.

    This machine has no problems connecting to a more traditional Internet connection: wired, wifi, free public, hotel room, airport, McDonalds, etc. And this phone has no problem putting other devices onto the Internet: friend's iPad, coworker's laptop, my desktop running windows 7 ultimate. There is just some disconnect between these two devices. If they had necks I would strangle them both.

    Here are a few of the things I have tried that I can think of off the top of my head:

    ON COMPUTER
    uninstalled virus protection
    disabled all firewalls
    Set IP/DNS to auto
    reboot


    ON PHONE APP
    cycled thru all 11 channels
    turned off WEP security
    turned off access control
    toggled MSS clamping
    toggled something called "routing fix"
    cycled thru all of the device profiles
    tried all setup methods: auto, WEXT (adhoc), Netd (master) Netd-Ndc (master)
    toggled wifi driver reloading
    toggled data
    reboot

    I also brought up the command prompt to compare the ipconfig/all readout on the government computer and the one on my XP machine (while both connected to the phone). One difference that I noticed was that on the computer with no problems, Net Bios over TCP/IP is enabled. On the computer that is not working, it is disabled. Naturally I tried to enable it, but I cannot get the readout to tell me that it is enabled. I go to the proper spot in the network properties (tried to post link but cant cause I have 0 posts; just google how to enable NetBIOS over tcpip XP and you can see something like what I did). Even after I try to enable NetBios like this, ipconfig/all is still saying disabled.

    So the easy question: how do I make this machine enable NetBIOS over TCP/IP?

    The hard question: if this doesn't work, how do I get Windows XP to play nice with my Android tethering app?

    The goal is to put my XP machine on the Internet thru my phone via wifi (usb is impractical due to another long story) so if there is another way to accomplish this, I would welcome the work-around.

    Best regards and thanks in advance,
    Aaron
     
    Aaron1983, Jan 10, 2013
    #1
    1. Advertisements

  2. Aaron1983

    Elizabeth23

    Joined:
    Dec 10, 2012
    Messages:
    4,874
    Likes Received:
    329
    Location:
    Florida
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.