Access Permissions on Shared Drives

Discussion in 'Windows XP Networking' started by 3guesses, Oct 21, 2018.

  1. 3guesses

    3guesses

    Joined:
    Oct 20, 2018
    Messages:
    8
    Likes Received:
    0
    Hi,

    I am trying to set up a simple file-server for an external USB drive (actually a few, but I'll just stick to 1 here) but I seem to be having problems with permissioning. My set-up is as follows:

    • 2 XP Pro SP3 machines, one acting as a workstation the other as a file server, each logged in locally using the same admin account with a common password
    • the server has an external USB drive attached which is mounted to the folder C:\files\DriveA
    • the Network Setup Wizard has been run on both machines
    • the folder C:\files on the server has been shared as "Files" through Windows Explorer and "Allow other users to change files" selected for the share

    The workstation can then see the contents of \\server\Files but can't see anything in the DriveA subfolder ("File Not Found"). I have done the same thing with a USB memory stick (mounted into a folder in the C:\files folder) and that is fine so I don't quite understand why the server won't let the workstation user see the files on the external USB drive. The only difference I can think of is that the memory stick is formatted to FAT while the external HDD is formatted to NTFS.

    One other difference is that when I select the Sharing tab for a folder on the workstation, it is different to the Sharing tab on the server: on the workstation, it just has the options "Do not share this folder" and "Share this folder", and in the "Share this folder" section it has a Permissions button and a Caching button; on the server there's a "Local sharing and security" section, then a "Network sharing and security" section which has the two options "Share this folder on the network" and "Allow network users to change my files".

    Anybody have any ideas?
     
    3guesses, Oct 21, 2018
    #1
    1. Advertisements

  2. 3guesses

    3guesses

    Joined:
    Oct 20, 2018
    Messages:
    8
    Likes Received:
    0
    For anybody interested, I think I have found the solution to this problem.

    What I had to do was share the drive using Windows Explorer (eg. right-click on E: drive in Explorer pane, select Sharing and Security, click on "If you understand the risk, etc", select "Share this folder", click on Apply then OK once permissions have finished being set), then delete the share using the command line (eg. "net share E /d"). The files will then be visible via the \\server\Files share.

    I think the key is to get Windows Explorer to set all the appropriate permissions for the drive but without creating a new share for the drive itself. A little convoluted...

    One anomaly remains: the "Sharing" dialogue is still different. No Idea what that's about!
     
    3guesses, Nov 8, 2018
    #2
    1. Advertisements

  3. 3guesses

    3guesses

    Joined:
    Oct 20, 2018
    Messages:
    8
    Likes Received:
    0
    Update:

    OK, so doing the above is not quite what I wanted to do as I also want to control access to the shared folders. What I actually needed to do instead was to deactivate simple file sharing (Control Panel->Folder Options->View: de-select "Use simple file sharing (recommended)". Once that is done I then get the more advanced Sharing tab and I can set the permissions for the shared folders. I had made the fundamental error of forgetting that WIndows was designed for dummies...
     
    3guesses, Nov 8, 2018
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.